JavaEar 专注于收集分享传播有价值的技术资料

Nginx - Invalid number of arguments in client_max_body_size

I'm trying to set client_max_body_size in my nginx config file.

server {
    listen 80;
    server_name ****.com;
    root ****;

    client_max_body_size 32m

    location / {
                try_files $uri /app.php$is_args$args;
        }

        location ~ ^/(app_dev|config)\.php(/|$) {
        fastcgi_pass 127.0.0.1:9000;
               fastcgi_split_path_info ^(.+\.php)(/.*)$;
            include fastcgi_params;

        fastcgi_param  SCRIPT_FILENAME  $realpath_root$fastcgi_script_name;
            fastcgi_param DOCUMENT_ROOT $realpath_root;
    }

        location ~ ^/app\.php(/|$) {
                fastcgi_pass  127.0.0.1:9000;
        fastcgi_split_path_info ^(.+\.php)(/.*)$;
            include fastcgi_params;

        fastcgi_param  SCRIPT_FILENAME  $realpath_root$fastcgi_script_name;
            fastcgi_param DOCUMENT_ROOT $realpath_root;

        internal;
        }
}

I'm getting error: invalid number of arguments in "client_max_body_size" directive in /etc/nginx/sites-enabled/****.com

Whats wrong with my conf?

1个回答

    最佳答案
  1. You forgot to terminate the line with semicolon. Has to be

    client_max_body_size 32m;