JavaEar 专注于收集分享传播有价值的技术资料

在" 加载包:........" 期间发生内部错误 (An internal error occurred during: "Loading bundle:........")

问题描述


英文原文

I just downloaded the most recent version of Eclipse Luna, and immediately installed the Aptana 3.0 plugin. After doing this I got a bunch of errors, the same errors as listed in this post:

An internal error occurred during: "Loading bundle[...]"

!ENTRY org.eclipse.core.jobs 4 2 2014-09-27 19:19:23.753 !MESSAGE An internal error occurred during: "Loading bundle: /opt/eclipse/configuration/org.eclipse.osgi/873/0/.cp/bundles/php.ruble". !STACK 0 java.lang.ClassCastException: org.eclipse.osgi.internal.framework.EquinoxConfiguration$1 cannot be cast to java.lang.String at org.jruby.util.OSEnvironment.getAsMapOfRubyStrings(OSEnvironment.java:90) at org.jruby.util.OSEnvironment.getSystemPropertiesMap(OSEnvironment.java:75) at org.jruby.RubyGlobal.defineGlobalEnvConstants(RubyGlobal.java:393) at org.jruby.RubyGlobal.createGlobals(RubyGlobal.java:358) at org.jruby.Ruby.init(Ruby.java:1078) at org.jruby.Ruby.newInstance(Ruby.java:186) at org.jruby.embed.internal.SingletonLocalContextProvider.getRuntime(SingletonLocalContextProvider.java:95) at org.jruby.embed.internal.EmbedRubyRuntimeAdapterImpl.runParser(EmbedRubyRuntimeAdapterImpl.java:166) at org.jruby.embed.internal.EmbedRubyRuntimeAdapterImpl.parse(EmbedRubyRuntimeAdapterImpl.java:93) at org.jruby.embed.ScriptingContainer.parse(ScriptingContainer.java:1163) at org.jruby.embed.ScriptingContainer.runScriptlet(ScriptingContainer.java:1223) at com.aptana.scripting.ScriptingEngine.getInitializedScriptingContainer(ScriptingEngine.java:292) at com.aptana.scripting.model.ScriptLoadJob.run(ScriptLoadJob.java:76) at com.aptana.scripting.model.AbstractScriptRunner.run(AbstractScriptRunner.java:144) at com.aptana.scripting.model.AbstractScriptRunner.run(AbstractScriptRunner.java:180) at com.aptana.scripting.ScriptingEngine.runScript(ScriptingEngine.java:274) at com.aptana.scripting.ScriptingEngine.runScript(ScriptingEngine.java:243) at com.aptana.scripting.model.BundleManager.loadScript(BundleManager.java:2032) at com.aptana.scripting.model.BundleManager$BundleLoadJob.run(BundleManager.java:129) at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)

Apparently there is a fix available for this, a patch can be applied from the updates for Eclipse 4.4. I found the patch Eclipse 4.4.1 Patches for bug 445122 and tried to install it. E4 RCP Patch (bugzillas 445122) 1.0.0 org.eclipse.e4.rcp.R441patch.feature.group Eclipse.org installed properly, but three others will not installed:

 Equinox CORE Feature Patch (bugzillas 445122)  1.0.0
 Equinox CORE SDK Patch (bugzillas 445122)  1.0.0
 Equinox Server CORE Patch (bugzillas 445122)   1.0.0

and when I restart Eclipse I am still encountering the same error, it does not appear to be fixed.


中文翻译

I just downloaded the most recent version of Eclipse Luna, and immediately installed the Aptana 3.0 plugin. After doing this I got a bunch of errors, the same errors as listed in this post:

An internal error occurred during: "Loading bundle[...]"

!ENTRY org.eclipse.core.jobs 4 2 2014-09-27 19:19:23.753 !MESSAGE An internal error occurred during: "Loading bundle: /opt/eclipse/configuration/org.eclipse.osgi/873/0/.cp/bundles/php.ruble". !STACK 0 java.lang.ClassCastException: org.eclipse.osgi.internal.framework.EquinoxConfiguration$1 cannot be cast to java.lang.String at org.jruby.util.OSEnvironment.getAsMapOfRubyStrings(OSEnvironment.java:90) at org.jruby.util.OSEnvironment.getSystemPropertiesMap(OSEnvironment.java:75) at org.jruby.RubyGlobal.defineGlobalEnvConstants(RubyGlobal.java:393) at org.jruby.RubyGlobal.createGlobals(RubyGlobal.java:358) at org.jruby.Ruby.init(Ruby.java:1078) at org.jruby.Ruby.newInstance(Ruby.java:186) at org.jruby.embed.internal.SingletonLocalContextProvider.getRuntime(SingletonLocalContextProvider.java:95) at org.jruby.embed.internal.EmbedRubyRuntimeAdapterImpl.runParser(EmbedRubyRuntimeAdapterImpl.java:166) at org.jruby.embed.internal.EmbedRubyRuntimeAdapterImpl.parse(EmbedRubyRuntimeAdapterImpl.java:93) at org.jruby.embed.ScriptingContainer.parse(ScriptingContainer.java:1163) at org.jruby.embed.ScriptingContainer.runScriptlet(ScriptingContainer.java:1223) at com.aptana.scripting.ScriptingEngine.getInitializedScriptingContainer(ScriptingEngine.java:292) at com.aptana.scripting.model.ScriptLoadJob.run(ScriptLoadJob.java:76) at com.aptana.scripting.model.AbstractScriptRunner.run(AbstractScriptRunner.java:144) at com.aptana.scripting.model.AbstractScriptRunner.run(AbstractScriptRunner.java:180) at com.aptana.scripting.ScriptingEngine.runScript(ScriptingEngine.java:274) at com.aptana.scripting.ScriptingEngine.runScript(ScriptingEngine.java:243) at com.aptana.scripting.model.BundleManager.loadScript(BundleManager.java:2032) at com.aptana.scripting.model.BundleManager$BundleLoadJob.run(BundleManager.java:129) at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)

Apparently there is a fix available for this, a patch can be applied from the updates for Eclipse 4.4. I found the patch Eclipse 4.4.1 Patches for bug 445122 and tried to install it. E4 RCP Patch (bugzillas 445122) 1.0.0 org.eclipse.e4.rcp.R441patch.feature.group Eclipse.org installed properly, but three others will not installed:

 Equinox CORE Feature Patch (bugzillas 445122)  1.0.0
 Equinox CORE SDK Patch (bugzillas 445122)  1.0.0
 Equinox Server CORE Patch (bugzillas 445122)   1.0.0

and when I restart Eclipse I am still encountering the same error, it does not appear to be fixed.

I just downloaded the most recent version of Eclipse Luna, and immediately installed the Aptana 3.0 plugin. After doing this I got a bunch of errors, the same errors as listed in this post:

An internal error occurred during: "Loading bundle[...]"

!ENTRY org.eclipse.core.jobs 4 2 2014-09-27 19:19:23.753 !MESSAGE An internal error occurred during: "Loading bundle: /opt/eclipse/configuration/org.eclipse.osgi/873/0/.cp/bundles/php.ruble". !STACK 0 java.lang.ClassCastException: org.eclipse.osgi.internal.framework.EquinoxConfiguration$1 cannot be cast to java.lang.String at org.jruby.util.OSEnvironment.getAsMapOfRubyStrings(OSEnvironment.java:90) at org.jruby.util.OSEnvironment.getSystemPropertiesMap(OSEnvironment.java:75) at org.jruby.RubyGlobal.defineGlobalEnvConstants(RubyGlobal.java:393) at org.jruby.RubyGlobal.createGlobals(RubyGlobal.java:358) at org.jruby.Ruby.init(Ruby.java:1078) at org.jruby.Ruby.newInstance(Ruby.java:186) at org.jruby.embed.internal.SingletonLocalContextProvider.getRuntime(SingletonLocalContextProvider.java:95) at org.jruby.embed.internal.EmbedRubyRuntimeAdapterImpl.runParser(EmbedRubyRuntimeAdapterImpl.java:166) at org.jruby.embed.internal.EmbedRubyRuntimeAdapterImpl.parse(EmbedRubyRuntimeAdapterImpl.java:93) at org.jruby.embed.ScriptingContainer.parse(ScriptingContainer.java:1163) at org.jruby.embed.ScriptingContainer.runScriptlet(ScriptingContainer.java:1223) at com.aptana.scripting.ScriptingEngine.getInitializedScriptingContainer(ScriptingEngine.java:292) at com.aptana.scripting.model.ScriptLoadJob.run(ScriptLoadJob.java:76) at com.aptana.scripting.model.AbstractScriptRunner.run(AbstractScriptRunner.java:144) at com.aptana.scripting.model.AbstractScriptRunner.run(AbstractScriptRunner.java:180) at com.aptana.scripting.ScriptingEngine.runScript(ScriptingEngine.java:274) at com.aptana.scripting.ScriptingEngine.runScript(ScriptingEngine.java:243) at com.aptana.scripting.model.BundleManager.loadScript(BundleManager.java:2032) at com.aptana.scripting.model.BundleManager$BundleLoadJob.run(BundleManager.java:129) at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)

Apparently there is a fix available for this, a patch can be applied from the updates for Eclipse 4.4. I found the patch Eclipse 4.4.1 Patches for bug 445122 and tried to install it. E4 RCP Patch (bugzillas 445122) 1.0.0 org.eclipse.e4.rcp.R441patch.feature.group Eclipse.org installed properly, but three others will not installed:

 Equinox CORE Feature Patch (bugzillas 445122)  1.0.0
 Equinox CORE SDK Patch (bugzillas 445122)  1.0.0
 Equinox Server CORE Patch (bugzillas 445122)   1.0.0

and when I restart Eclipse I am still encountering the same error, it does not appear to be fixed.

I just downloaded the most recent version of Eclipse Luna, and immediately installed the Aptana 3.0 plugin. After doing this I got a bunch of errors, the same errors as listed in this post:

An internal error occurred during: "Loading bundle[...]"

!ENTRY org.eclipse.core.jobs 4 2 2014-09-27 19:19:23.753 !MESSAGE An internal error occurred during: "Loading bundle: /opt/eclipse/configuration/org.eclipse.osgi/873/0/.cp/bundles/php.ruble". !STACK 0 java.lang.ClassCastException: org.eclipse.osgi.internal.framework.EquinoxConfiguration$1 cannot be cast to java.lang.String at org.jruby.util.OSEnvironment.getAsMapOfRubyStrings(OSEnvironment.java:90) at org.jruby.util.OSEnvironment.getSystemPropertiesMap(OSEnvironment.java:75) at org.jruby.RubyGlobal.defineGlobalEnvConstants(RubyGlobal.java:393) at org.jruby.RubyGlobal.createGlobals(RubyGlobal.java:358) at org.jruby.Ruby.init(Ruby.java:1078) at org.jruby.Ruby.newInstance(Ruby.java:186) at org.jruby.embed.internal.SingletonLocalContextProvider.getRuntime(SingletonLocalContextProvider.java:95) at org.jruby.embed.internal.EmbedRubyRuntimeAdapterImpl.runParser(EmbedRubyRuntimeAdapterImpl.java:166) at org.jruby.embed.internal.EmbedRubyRuntimeAdapterImpl.parse(EmbedRubyRuntimeAdapterImpl.java:93) at org.jruby.embed.ScriptingContainer.parse(ScriptingContainer.java:1163) at org.jruby.embed.ScriptingContainer.runScriptlet(ScriptingContainer.java:1223) at com.aptana.scripting.ScriptingEngine.getInitializedScriptingContainer(ScriptingEngine.java:292) at com.aptana.scripting.model.ScriptLoadJob.run(ScriptLoadJob.java:76) at com.aptana.scripting.model.AbstractScriptRunner.run(AbstractScriptRunner.java:144) at com.aptana.scripting.model.AbstractScriptRunner.run(AbstractScriptRunner.java:180) at com.aptana.scripting.ScriptingEngine.runScript(ScriptingEngine.java:274) at com.aptana.scripting.ScriptingEngine.runScript(ScriptingEngine.java:243) at com.aptana.scripting.model.BundleManager.loadScript(BundleManager.java:2032) at com.aptana.scripting.model.BundleManager$BundleLoadJob.run(BundleManager.java:129) at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)

Apparently there is a fix available for this, a patch can be applied from the updates for Eclipse 4.4. I found the patch Eclipse 4.4.1 Patches for bug 445122 and tried to install it. E4 RCP Patch (bugzillas 445122) 1.0.0 org.eclipse.e4.rcp.R441patch.feature.group Eclipse.org installed properly, but three others will not installed:

 Equinox CORE Feature Patch (bugzillas 445122)  1.0.0
 Equinox CORE SDK Patch (bugzillas 445122)  1.0.0
 Equinox Server CORE Patch (bugzillas 445122)   1.0.0

and when I restart Eclipse I am still encountering the same error, it does not appear to be fixed.

1个回答

    最佳答案

  1. 英文原文

    I found that the patch (https://bugs.eclipse.org/bugs/show_bug.cgi?id=445122) fixed all of the errors I had installing the Aptana plugin.


    中文翻译

    我找到了补丁( https://bugs.eclipse.org/ bugs / show_bug.cgi?id = 445122 )修复了我安装Aptana插件的所有错误。

    I found that the patch (https://bugs.eclipse.org/bugs/show_bug.cgi?id=445122) fixed all of the errors I had installing the Aptana plugin.

    我找到了补丁( https://bugs.eclipse.org/ bugs / show_bug.cgi?id = 445122 )修复了我安装Aptana插件的所有错误。