JavaEar 专注于收集分享传播有价值的技术资料

2个回答

    最佳答案
  1. Instead of

    pip [...]
    

    Try doing

    python -m pip [...]
    

    Can't really help more without more info.

  2. 参考答案2
  3. I think your version of pip is old. You need to upgrade it first, like this:

    pip install -U pip
    

    You may need to upgrade setuptools too:

    pip install -U setuptools
    

    Since google-assistant-library is available as a wheel, you need to install wheel too:

    pip install wheel
    

    I don't know if you can do that with Raspberry Pi, but I recommend you to used a virtualenv. That way, you have a fresh and isolated Python executable and a recent version of pip.

    virtualenv your_proj
    source your_proj/bin/activate
    pip install wheel
    pip install google-assistant-library